Xubuntu: Fehlermeldung nach Login

Montag 2. Dezember 2019 von Torsten

Seit einiger Zeit trübt eine lästige Fehlermeldung die Xubuntu-Freude…Dieser Artikel dokumentiert die Fehlersuche und bietet eine mögliche Lösung…

Problembeschreibung:

Nach dem Login, also nach der Benutzeranmeldung erscheint eine Fehlermeldung “Es wurde ein Problem mit einer Systemanwendung festgestellt“. Außer dieser etwas lästigen Fehlermeldung sind aber keine Systemprobleme erkennbar. Es kann also normal mit dem System gearbeitet werden. Die Funktion das Problem zu melden funktioniert aber auch nicht.

Nach einiger Zeit hatte ich mich an die Fehlermeldung gewöhnt und habe sie einfach weggeklickt. Irgendwann ist sie dann auch von alleine verschwunden ohne das ich irgendetwas im System konfigurieren musste. Einige Updates später tauchte diese Fehlermeldung wieder auf. Wie schon zuvor verschwand der Fehler dann irgendwann wieder wie von Geisterhand. So sollte es eine Weile hin und her gehen. Da diese Fehlermeldung aber immer wieder auftauchte und einfach nicht verschwinden wollte, war irgendwann klar das eine systematische Fehlersuche wohl dringend nötig ist…

Zusätzlich tricky an diesem Fehler: Er tauchte nicht an jedem meiner Xubuntu Systeme auf.

Fehlersuche:

Von Anfang an war für mich klar, es handelt sich um einen Xubuntu internen Fehler. Also irgendwas was die Xubunut Leute auf ihrer Bug-Liste haben sollten und es schon mit der Zeit behoben wird. Da der Fehler ja auch nicht an allen Xubuntu Systemen auftauchte, fiel mein Verdacht auch auf etwas Hardware-spezifisches…

Da der Fehler ja auch nach einer Benutzer-Neuanmeldung auftrat, schloss ich Boot-Probleme aus. Meine Fehlersuche führte mich zuerst in die Logbücher des betroffenen Systems. Doch dort wurde ich nicht fündig.

Die nächste Anlaufstelle war nun die Konfiguration für die Sitzung und das Startverhalten (unter Einstellungen). Dort untersuchte ich intensiv die Autostart-Anwendungen.

Vor irgendeiner Anpassung habe ich per Screenshot festgehalten welche Anwendungen hier für den Autostart aktiviert waren.

Im nächsten Schritt habe ich einfach nach und nach eine Anwendung nach der anderen deaktiviert. Nach jeder Deaktivierung immer vom System abgemeldet und neu angemeldet. Ich hatte ja schon herrausgefunden, dass die Fehlermeldung durch eine Neuanmeldung auch “ausgelöst“ wird…

Nach einigen Experimenten konnte ich den update-notifier als Fehlerursache ermitteln.

Fehlerursache:

Der update-notifier löst diese Fehlermeldung aus. Sobald der deaktiviert ist, ist wieder Ruhe im System ohne lästige Fehlermeldung. Updates müssen dann aber manuell eingespielt werden…

Im Terminal habe ich den Befehl “update-notifier“ mal nur aus Neugier abgefeuert. Zack hatte ich wieder die Fehlermeldung vor meiner Nase und auch eine interessante Terminalmeldung:

  • GtkDialog mapped without a transient parent. This is not discouraged.

Eine Internetrecherche führte dann zu dem Ergebnis, dass es sich hier um das GimpTool Kit handelt, eine Grafikbibliothek die auch für Infofenster und Fehlermeldungen zuständig ist.

Offene Fragen:

Die Problemlösung den update-notifier zu deaktivieren reicht mir zwar als Notlösung bis die Experten von Xubuntu das Problem richtig gelöst haben, trotzdem bleibt die Frage: Warum erscheint dieser Fehler nicht grundsätzlich auf allen Xubuntu-Systemen?

Dieser Beitrag wurde erstellt am Montag 2. Dezember 2019 um 08:00 und abgelegt unter Allgemein. Kommentare zu diesen Eintrag im RSS 2.0 Feed. Sie können zum Ende springen und ein Kommentar hinterlassen. Pings sind im Augenblick nicht erlaubt.

Kommentar schreiben