Calc: Wenn-Funktion

Dienstag 17. März 2020 von Torsten

Welche Inhalte eine Zelle anzeigt, lässt sich von einer Bedingung abhängig machen. Dieser Artikel stellt die Wenn-Funktion von Calc vor…

Die Wenn-Funktion mit Experiment 1:

Für das erste Experiment wird folgende Tabelle in Calc erstellt…

In Zelle B3 wird der Monatsname Januar eingetragen. In Zelle B4 wird der Monatsname Februar eingetragen. In Zelle B5 wird der Monatsname März eingetragen. In Zelle C2 wird der Text “Ausgaben“ eingetragen. In Zelle C3 wird der Wert 50 eingetragen. In Zelle C4 wird der Wert 60 eingetragen. In Zelle C5 wird der Wert 70 eingetragen…

In Zelle D3 wird nun folgende Formel eingetragen:

  • =WENN(C3<100;“OK“;“Warnung“)

Der Wert in Zelle C3 soll also geprüft werden, ob er kleiner ist als der Wert 100. Wenn der Wert in Zelle C3 kleiner als 100 ist, soll der Text “OK“ ausgegeben werden. Wenn der Wert aber gleich oder größer 100 ist soll eine Warnung ausgegeben werden.

Die Formel kann nun in die Zellen D4 und D5 kopiert werden. Wenn man jetzt mit den Werten experimentiert, stellt man fest, dass die Ausgabe in D3, D4 und D5 immer abhängig ist von den Werten der Zellen C3 bis C5.

In den Klammern der Wenn-Funktion wird also erst die Bedingung festgelegt. Mit einem Semikolon werden die Bereiche getrennt. Es folgt die Dann-Ausgabe in Anführungszeichen. Getrennt mit einem Semikolon folgt dann die Sonst-Ausgabe…

Die Wenn-Funktion mit Experiment 2:

In Zelle C10 wird folgende Formel eingegeben…:

  • =WENN(B10=“Hans“;“guter Mensch“; „schlechter Mensch“)

In Zelle B10 können nun verschiedene Namen eingegeben werden. Nur der Name “Hans“ führt nun in C10 zur Ausgabe “guter Mensch“…

Dieser Beitrag wurde erstellt am Dienstag 17. März 2020 um 08:00 und abgelegt unter Allgemein. Kommentare zu diesen Eintrag im RSS 2.0 Feed. Sie können zum Ende springen und ein Kommentar hinterlassen. Pings sind im Augenblick nicht erlaubt.

Kommentar schreiben